個人網頁連不去進去

linux相關問題與技術

個人網頁連不去進去

文章duckchuang » 週三 2月 15, 2006 3:59 pm

各位前輩
小弟有個問題,小弟架設一個測試的網站想要測試個人網站的部分!也依照一般書籍的寫法
將UserDir public_html
的註解取消,也在使用者下面建立出該資料夾
chmod 755 711 或者 644 index.html都做了!
但是當我連到該網站卻出現下面的訊息
You don't have permission to access /~energy/ on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------------

Apache/2.0.53 (Fedora) Server at

不知道是不是因為太久沒接觸LINUX!設定不知道錯在哪裡?
duckchuang
 
文章: 106
註冊時間: 週一 7月 07, 2003 1:23 pm
來自: 西松

Re: 個人網頁連不去進去

文章黑牌種子教師 » 週三 2月 15, 2006 6:35 pm

duckchuang 寫:各位前輩
小弟有個問題,小弟架設一個測試的網站想要測試個人網站的部分!也依照一般書籍的寫法
將UserDir public_html
的註解取消,也在使用者下面建立出該資料夾
chmod 755 711 或者 644 index.html都做了!
但是當我連到該網站卻出現下面的訊息
You don't have permission to access /~energy/ on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------------

Apache/2.0.53 (Fedora) Server at

不知道是不是因為太久沒接觸LINUX!設定不知道錯在哪裡?


UserDir public_html 這段內容是否能貼出來. 不然不知道如何幫忙?
黑牌種子教師
 

SELINUX

文章lai » 週三 2月 15, 2006 9:08 pm

原因1.public_html沒開
<IfModule mod_userdir.c>
#
# UserDir is disabled by default since it can confirm the presence
# of a username on the system (depending on home directory
# permissions).
#
#UserDir disable

#
# To enable requests to /~user/ to serve the user's public_html
# directory, remove the "UserDir disable" line above, and uncomment
# the following line instead:
#
UserDir public_html

</IfModule>



原因2.權限
chmod -R 755 /home

原因3.安全向增強SELINUX

裝的時候裝進去了
要改權限或disable
lai
 

Re: SELINUX

文章duckchuang » 週四 2月 16, 2006 7:56 am

lai 寫:原因1.public_html沒開
<IfModule mod_userdir.c>
#
# UserDir is disabled by default since it can confirm the presence
# of a username on the system (depending on home directory
# permissions).
#
#UserDir disable

#
# To enable requests to /~user/ to serve the user's public_html
# directory, remove the "UserDir disable" line above, and uncomment
# the following line instead:
#
UserDir public_html

</IfModule>



原因2.權限
chmod -R 755 /home

原因3.安全向增強SELINUX

裝的時候裝進去了
要改權限或disable


請問一下如果是第三個要怎麼解決呢?
第一、二!我都試過,問題還是一樣!
duckchuang
 
文章: 106
註冊時間: 週一 7月 07, 2003 1:23 pm
來自: 西松

Re: SELINUX

文章黑牌種子教師 » 週四 2月 16, 2006 10:20 am

duckchuang 寫:
lai 寫:原因1.public_html沒開
<IfModule mod_userdir.c>
#
# UserDir is disabled by default since it can confirm the presence
# of a username on the system (depending on home directory
# permissions).
#
#UserDir disable

#
# To enable requests to /~user/ to serve the user's public_html
# directory, remove the "UserDir disable" line above, and uncomment
# the following line instead:
#
UserDir public_html

</IfModule>



原因2.權限
chmod -R 755 /home

原因3.安全向增強SELINUX

裝的時候裝進去了
要改權限或disable


請問一下如果是第三個要怎麼解決呢?
第一、二!我都試過,問題還是一樣!


主網頁也不能連結嗎? 如果主網頁能夠連結,是否也是第三個問題呢? (當然不是!)

如果主網頁能連結,如果你也都做了以上所提及權限問題,你還是貼出那個設定.
(不是要<IfModule mod_userdir.c>這個設定)
黑牌種子教師
 

Re: SELINUX

文章黑牌種子教 » 週四 2月 16, 2006 10:25 am

黑牌種子教師 寫:主網頁也不能連結嗎? 如果主網頁能夠連結,是否也是第三個問題呢? (當然不是!)

如果主網頁能連結,如果你也都做了以上所提及權限問題,你還是貼出那個設定.
(不是要<IfModule mod_userdir.c>這個設定)


如果也貼出 httpd 的 access.log 與 error.log 的該連線訊息更好!
黑牌種子教
 

more /etc/sysconfig/selinux

文章lai » 週四 2月 16, 2006 7:52 pm

more /etc/sysconfig/selinux

#....
#....
#....
#...
#....

SELINUX=disabled

存檔.....reboot
lai
 

post log 檔看最清楚

文章coperchang » 週五 2月 17, 2006 10:23 am

log 檔上面有比較清楚的錯誤資訊,若沒有這些資訊其實很難知道問題的所在,
請post /var/log/httpd/error.log 之類的資訊。
我們很想幫你,但是不知如何著手。
coperchang
 

Re: post log 檔看最清楚

文章訪客 » 週五 2月 17, 2006 7:44 pm

coperchang 寫:log 檔上面有比較清楚的錯誤資訊,若沒有這些資訊其實很難知道問題的所在,
請post /var/log/httpd/error.log 之類的資訊。
我們很想幫你,但是不知如何著手。


應該是解決了, 我看回應的比問的人還熱心,問的人是測試,所以隨便回應就好,那麼熱心做什麼。這年頭幫忙要看.................
訪客
 

Re: post log 檔看最清楚

文章黑牌種子教師 » 週六 2月 18, 2006 12:57 am

Anonymous 寫:
coperchang 寫:log 檔上面有比較清楚的錯誤資訊,若沒有這些資訊其實很難知道問題的所在,
請post /var/log/httpd/error.log 之類的資訊。
我們很想幫你,但是不知如何著手。


應該是解決了, 我看回應的比問的人還熱心,問的人是測試,所以隨便回應就好,那麼熱心做什麼。這年頭幫忙要看.................


Fedora 以上問題百分之九十九來自 httpd.conf 設定!
(這篇就只追蹤而不再回應了)
黑牌種子教師
 

Re: post log 檔看最清楚

文章duckchuang » 週一 2月 20, 2006 7:04 pm

黑牌種子教師 寫:
Anonymous 寫:
coperchang 寫:log 檔上面有比較清楚的錯誤資訊,若沒有這些資訊其實很難知道問題的所在,
請post /var/log/httpd/error.log 之類的資訊。
我們很想幫你,但是不知如何著手。


應該是解決了, 我看回應的比問的人還熱心,問的人是測試,所以隨便回應就好,那麼熱心做什麼。這年頭幫忙要看.................


Fedora 以上問題百分之九十九來自 httpd.conf 設定!
(這篇就只追蹤而不再回應了)



真的很感謝各位熱心的幫忙!
也很想POST上來相關訊息!
不過最近在忙數位學生證拍照,要拍將近2000張!
所以才沒POST!今天更慘!發現一台機器的RAID 5其中一棵硬碟出問題!
得趕快拿回原本的硬碟放上去!在ReBuliding.....................................
真的是.......................................
duckchuang
 
文章: 106
註冊時間: 週一 7月 07, 2003 1:23 pm
來自: 西松

Re: post log 檔看最清楚

文章duckchuang » 週二 2月 21, 2006 8:52 am

感謝各位的大力協助
小弟把該LOG檔 先貼關於個人網頁部分的設定
謝謝!

<IfModule mod_userdir.c>
#
# UserDir is disabled by default since it can confirm the presence
# of a username on the system (depending on home directory
# permissions).
#
#UserDir disable

#
# To enable requests to /~user/ to serve the user's public_html
# directory, remove the "UserDir disable" line above, and uncomment
# the following line instead:
#
UserDir public_html

</IfModule>

#
# Control access to UserDir directories. The following is an example
# for a site where these directories are restricted to read-only.
#
<Directory /home/*/public_html>
AllowOverride FileInfo AuthConfig Limit
Options MultiViews SymLinksIfOwnerMatch IncludesNoExec
<Limit GET POST OPTIONS>
Order allow,deny
Allow from all
</Limit>
<LimitExcept GET POST OPTIONS>
Order deny,allow
Deny from all
</LimitExcept>
</Directory>

小弟是依照書本上的寫法來設定!就不知道那邊出問題哩!
duckchuang
 
文章: 106
註冊時間: 週一 7月 07, 2003 1:23 pm
來自: 西松

Re: post log 檔看最清楚

文章黑牌種子教師 » 週二 2月 21, 2006 11:27 am

duckchuang 寫:感謝各位的大力協助
小弟把該LOG檔 先貼關於個人網頁部分的設定
謝謝!

<IfModule mod_userdir.c>
#
# UserDir is disabled by default since it can confirm the presence
# of a username on the system (depending on home directory
# permissions).
#
#UserDir disable

#
# To enable requests to /~user/ to serve the user's public_html
# directory, remove the "UserDir disable" line above, and uncomment
# the following line instead:
#
UserDir public_html

</IfModule>

#
# Control access to UserDir directories. The following is an example
# for a site where these directories are restricted to read-only.
#
<Directory /home/*/public_html>
AllowOverride FileInfo AuthConfig Limit
Options MultiViews SymLinksIfOwnerMatch IncludesNoExec
<Limit GET POST OPTIONS>
Order allow,deny
Allow from all
</Limit>
<LimitExcept GET POST OPTIONS>
Order deny,allow
Deny from all
</LimitExcept>
</Directory>

小弟是依照書本上的寫法來設定!就不知道那邊出問題哩!


以上看來沒問題.

是否還少設定一個 ! UserDir disable 即在前方加 # 成 #UserDir disable

有興趣滑鼠按右鍵反白那些字, 如果這個也設好了, 那可能愛莫能助了!
黑牌種子教師
 

Re: post log 檔看最清楚

文章黑牌種子教師 » 週二 2月 21, 2006 11:33 am

<IfModule mod_userdir.c>
#
# UserDir is disabled by default since it can confirm the presence
# of a username on the system (depending on home directory
# permissions).
#

#UserDir disable

#
# To enable requests to /~user/ to serve the user's public_html
# directory, remove the "UserDir disable" line above, and uncomment
# the following line instead:
#
UserDir public_html

</IfModule>

沒注意看,你已經設定了!
黑牌種子教師
 

Re: post log 檔看最清楚

文章黑牌種子教師 » 週二 2月 21, 2006 2:18 pm

從新整理一下 :

個人裝好 Linux 且設定好 Httpd.conf 後, 會先連結一次 http:// xxx.xxx.xxx.xxx 看是否運作 ?
如果不能運作再找問題, 如果可以運作再試 php 的 phpinfo(), 不可運作找問題?
以上都可運作再試 USER 的網頁運作.

這些 USER 應該要先有基本的帳號 (/ETC/PASSWD 有他們的帳號).
(好像在 TRUSTIX 下, 沒有帳號的目錄是無法連結到網頁)
如果 CHMOD 701 /HOME/USERS/PUBLIC_HTML 無法運作,
直接以 CHMOD -R 755 /HOME/USERS/PUBLIC_HTML
而最常見的是未 CHOWN -R USER /HOME/USERS 那些檔案可能還是 ROOT 擁有者.

<Directory /home/*/public_html> 這個目錄設定可能要比對一下實際使用者目錄位置, 在 TRUSTIX 為 <Directory /home/users/*/public_html> .
之前也幫人處理過 FC4 這問題, 印像中只 UserDir disable 改為 UserDir enable (我非 #UserDir disable) 與去除這裡的 [#] UserDir public_html . 而有沒有改 <Directory /home/*/public_html> 已經忘了!

剩下的是那個連結後的 LOG 檔記錄為何? (連結 USER 網頁的那筆記錄 ACCESS.LOG 與 ERROR.LOG)
黑牌種子教師
 

下一頁

回到 linux技術討論

誰在線上

正在瀏覽這個版面的使用者:沒有註冊會員 和 0 位訪客

cron